Jump to content United States-English
HP.com Home Products and Services Support and Drivers Solutions How to Buy
 Contact HP
HP.com home
HP Tru64 UNIX Version 5.1B-2 and Higher: Patch Kit Installation Instructions > Appendix B Common Error, Warning, and Informational Messages

Patch Preinstallation Check and Installation Messages

 

Table of Contents
Glossary
Index
Content starts here

The following sections describe messages you might see when running the dupatch preinstallation check or installation functions.

Patch Installation Blocked by Unknown System File


 

Source: dupatch preinstallation check or installation.

Problem: The installation of a specific patch is blocked due to an existing system file that is unknown.

Cause: This situation usually occurs when system files are placed on the system through manual intervention. For example, this may have been the result of installing a Customer-Specific patch received from HP Services or a system administrator's customization of a Tru64 UNIX file.

Until you confirm otherwise, the unknown system files should be viewed as intentional customizations that are important for proper system operation. As such, care should be taken to understand why the system files have been customized.

Action: Determine the origin of the existing unknown system files. The steps you take will be determined by the reason your system files were manually changed. See “Creating a Baseline” for more information.

Output:

Checking patch prerequisites and patch file applicability ...
       (depending upon the number of patches you select, this may take a while)    
 -------------------------------------------------------------------------
     Problem installing:

      - DIGITAL_UNIX_V4.0F / Common Desktop Environment (CDE) Patches:

             Patch 0326.00 - CDE Login Correction

             ./usr/dt/bin/dtwm:
                     its origin cannot be identified.

     This patch will not be installed.
  -------------------------------------------------------------------------
        * Following patch(es) failed in prerequisite/file applicability check:

      - TRU64_UNIX_V4.0D / Common Desktop Environment (CDE) Patches:
             Patch 0326.00 - CDE Login Correction

Patch Installation Blocked by Missing System File


 

Source: dupatch preinstallation check or installation.

Problem: Installation of a specific patch is blocked due to missing system file.

Causes: This situation usually occurs when a system file that was installed with setld is manually removed from the system. The file is marked as installed in the system inventory records.

Action: Determine why the system file is missing and whether it is safe to enable dupatch to install the blocked patch. See “Creating a Baseline” for more information.

Output:

     Checking patch prerequisites and patch file applicability...
       (depending upon the number of patches you select, this may take a while)
     -------------------------------------------------------------------------

     Problem installing:

      - DIGITAL_UNIX_V4.0F / Commands, Shells, & Utility Patches:
             Patch 0236.00 - vi Editor Correction

        ./usr/bin/vedit:
                does not exist on your system,
                however, it is in the inventory of installed subsets.

      This patch will not be installed.

      -------------------------------------------------------------------------
         * Following patch(es) failed in prerequisite/file applicability check:

       - DIGITAL_UNIX_V4.0F / Commands, Shells, & Utility Patches:
              Patch 0236.00 - vi Editor Correction

Installation Blocked by Layered Product Collision


 

Source: dupatch preinstallation check or installation.

Problem: The installation of a specific patch is blocked due to an existing system file that is installed by a layered product.

Causes: A small set of layered products deliver updated Tru64 UNIX operating system files.

Action: To resolve this situation contact the Product Customer Services representative.

Output:

    Checking patch prerequisites and patch file applicability...
       (depending upon the number of patches you select, this may take a while)
     -------------------------------------------------------------------------

     Problem installing:

      - TRU_UNIX_V4.0F / Network Patches:
             Patch 0182.00 - xti/streams Interface Module Correction

             ./sys/BINARY/xtiso.mod:
                     is installed by:

                                     BLTLPCONFLICTTEST410

                     and can not be replaced by this patch.

     This patch will not be installed.

     -------------------------------------------------------------------------

        * Following patch(es) failed in prerequisite/file applicability check:

      - DIGITAL_UNIX_V4.0F / Network Patches:
             Patch 0182.00 - xti/streams Interface Module Correction

Patch Installation Blocked by Dependencies on Other Patches


 

Source: dupatch preinstallation check or installation.

Problem: The installation of a specific patch is blocked due to its dependency on other uninstalled patches.

Causes: This usually occurs when you miss the selection of all dependent patches. It only occurs in old style patch kits.

Action: Through the dupatch Installation Menu, take one of the following actions:

  • Reselect the patches including the noted dependent patch and attempt reinstallation; dupatch will notify you of other missing dependent patches.

  • Select all patches and proceed with patch installation.

Output:

    SAMPLE OUTPUT:

     Checking patch prerequisites and patch file applicability...
       (depending upon the number of patches you select, this may take a while)
     -------------------------------------------------------------------------

     Problem installing:

      - DIGITAL_UNIX_V4.0F / Security Related Patches:
             Patch 0579.01 - Security, Various Kernel Fixes (SSRT0482U)

     requires the existence of the following un-installed/un-selected subset(s):

      - TruCluster_V1.6 / Filesystem Patches:
             Patch 0037.00 - Support For New AdvFS Mount Option "-o noatimes"

      - TruCluster_V1.6 / ASE Availability Manager (AM) Patches:
             Patch 0033.00 - Kern Mem Fault And simple_lock Panic Correction

     This patch will not be installed.

     -------------------------------------------------------------------------
        * Following patch(es) failed in prerequisite/file applicability check:

      - TRU64L_UNIX_V4.0F / Security Related Patches:
             Patch 0579.01 - Security, Various Kernel Fixes (SSRT0482U)

Patch Installation Blocked by Missing Product Subset


 

Source: dupatch preinstallation check or installation.

Problem: A specific patch cannot be installed because the product software subset is not installed on your system.

Causes: This is usually an informational message and no further action is required. However, this message may also occur due to an internal patch kit error that results in an incorrectly specified patch dependency.

Action: If the specific patch being blocked is the only patch being blocked you can assume this is an informational message. It may be an internal patch kit error if there are other patches whose installation is blocked by the patch whose subset is not installed. As a workaround, if you need one of the other patches whose installation is blocked, you can install the optional Tru64 UNIX or TCR release subset and reinstall the patches.

Output:

    Checking patch prerequisites and patch file applicability...
       (depending upon the number of patches you select, this may take a while)
     -------------------------------------------------------------------------

     Problem installing:

      - TruCluster_V1.6 / Cluster Kernel Patches:
             Patch 0035.00 - rm_spur Driver Correction

     requires the existence of the following un-installed/un-selected subset(s):

     - TruCluster_V1.6 - subset: TCRMCA141

     This patch will not be installed.

     ------------------------------------------------------------------------- 
       * Following patch(es) failed in prerequisite/file applicability check:

      - TruCluster_V1.6 / Cluster Kernel Patches:
             Patch 0035.00 - rm_spur Driver Correction

Patch Installation Blocked by Disk Space


 

Source: dupatch preinstallation check or installation.

Problem: The system disk did not have enough space to install patches.

Causes: This occurs when there is not enough disk space in /, /var, or /usr partitions for dupatch to archive the existing system files and move the patched files into place.

Action: Provide the necessary disk space and reinstall patches. If you cannot provide enough system disk space through other means, you may want to make /var/adm/patch/backup a symbolic link to or NFS-mount another file system that is not related to the /, /var, or /usr partitions.

Output:

Checking patch prerequisites once more...
       (depending upon the number of patches you select, this may take a while)

     ./usr/lbin/fitset:
     file system /whd needs 65829 Kbytes more to install the software specified.

            There is not enough file system space to install all the patches.
            you have selected.

            Please press RETURN to start another selection.
                      .
                      .
                      .

Patch Installation Blocked by Installed Patch or Subset


 

Source: dupatch preinstallation check or installation.

Problem: The patch you are trying to install is built so it cannot supersede the later revision patch or subset that is installed on your system.

Causes: This applicability feature is used to ensure that your system is not regressed through the installation of older code.

Action: If the situation is caused by a Release patch being blocked by a layered product or other subsets, contact your service provider.

Output:

Problem installing:

 - DIGITAL_UNIX_V4.0D / Filesystem Patches:
        Patch   00016.01 - System Run Level Correction

        ./sbin/.new..bcheckrc:
                is installed by:


 - DIGITAL_UNIX_V4.0D:
        Patch C 00484.01

                and can not be replaced by this patch.

This patch will not be installed.

Patch Installation Blocked by an Existing CSP


 

Source: dupatch preinstallation check or installation.

Problem: Release patches will not automatically supersede a Customer-Specific patch (CSP).

Causes: A file you are trying to update with a Release patch has been previously updated through the installation of a CSP. The Release patch does not have any knowlege as to whether it contains fixes contained in CSPs.

Action: Determine if the CSP is included in the Release Patch Kit:

  • If yes, then you can safely remove the CSP (via dupatch) and reinstall the Release patch .

  • If no, contact your service provider to determine how to proceed.

Output:

Problem installing:
 
 - DIGITAL_UNIX_V4.0F / Commands, Shells, & Utility Patches:
         Patch   00444.00 - Fixes sort problem when running in Japanese locale
 
         ./usr/bin/sort:
                is installed by Customer Specific Patch (CSP):
 
  - DIGITAL_UNIX_V4.0F:
         Patch C 00187.00
 
                and can not be replaced by this patch. To install this patch,
                you must first remove the CSP using dupatch. Before performing
                this action, you should contact your Service
                Representative to determine if this patch kit contains the
                CSP. If it does not, you may need to obtain a new CSP in order 
                to install the patch kit and retain the CSP fix.

The dupatch Tools Are Outdated


 

Source: dupatch preinstallation check or installation.

Problem: Patch tool set residing on system are not the most recent version.

Causes: If the dupatch utility delivered with the patch kit determines that the tools residing on the system are not consistent with the patch kit, it will copy over updated versions of utilities used by dupatch.

Action: This is an informational message and no further action is required.

Output:

  Patch tools need to be installed or updated on your system.
	Please invoke the command as the super-user (root) first.

	* A new version of patch tools required for patch management 
	  is now being installed on your system.

     

Some Patches Must Be Made Reversible


 

Source: dupatch preinstallation check or installation.

Causes: The user tried to install a patch as nonreversible; however, the patch in question must be installed as reversible.

Action: This is an informational message and no further action is required.

Output:

* The following patch(es) are required to be reversible and 
      will be made reversible automatically:

 - DIGITAL_UNIX_V4.0F / Commands, Shells, & Utility Patches:
        Patch C 00187.00 - v 4.0f patch E C187.00         
Printable version
Privacy statement Using this site means you accept its terms
2006 Hewlett-Packard Development Company, L.P.